Setting up the Etekcity WiFi Smart Plug with the VeSync app and 2.4 GHz connection

wifi outlet in outletThe Etekcity WiFi Smart Plug Mini Outlet with Energy Monitoring (2 Pack), Works with Amazon Alexa Echo, No Hub Required, 1 Minute to Set Up, White is a good smart outlet. It goes for about $30 for a pair [1].

I saw they had a claim that installation is under 1 minute, but that was not my case. It took about 15 minutes to figure it out the first time. Hopefully, this helps.

There is no instruction manual that comes in the box with the outlet, just some text on the back to download the VeSync Outlet on Google Play.

  • Tip – Do not download their other apps, they will not work with your outlet.

In the app, assuming you want to use the outlet with Alexa, create an account.

  • Tip – Unless you are using the timer in the app, buying the outlet to just use the app to turn the lights on/off would be a waste of money. I don’t even recommend it since the app is junk.

When adding your outlet to the app, follow the instructions in the app but select APN. The other way to app outlets seems like it is just broken.

Next comes the major problem that causes confusion with these outlets: they only support a 2.4 GHz connection.

  • Background – A new, modern router will usually have a 2.4 GHz and a 5 GHz connection. Default settings on the router will also set the name and password on these two connections to be the same. When your new phone connects to your network, it will be on the 5 GHz connection, but the app will complain that you need to connect to a 2.4 GHz connection.

You will need to go into your router’s admin page, find your networks, and rename your main WiFi network into two different WiFi networks.

xfinity admin page

  • Security Tip – If your router supports multiple networks, create a network and password just for your Internet of Things (IoT) devices. If your router will also prevent local network access, even better.

On your phone, connect to the 2.4 GHz connection and follow the rest of the steps in the app.

Then to get it working with Alexa, follow VeSync’s instructions.



This entry was posted in Android Apps, Hardware, How-To and tagged , , , , , , , , . Bookmark the permalink.

18 Responses to Setting up the Etekcity WiFi Smart Plug with the VeSync app and 2.4 GHz connection

  1. Bill W says:

    Found your post when I was having difficulty pairing a set I received for Christmas. Glad to see I’m not the only person having difficulty getting it set up. Curiously, the second outlet in the box paired flawlessly – but I plugged it in to an outlet in the same room as the Wifi access point before starting the process. Getting it set up with Alexa was “tedious”, but I ultimately succeeded. I was also able to get the original outlet paired/configured successfully after rebooting my phone (the outlet just appeared in the list in the VeSync app after the reboot, despite the fact that the initial setup never appeared to complete successfully).
    Also, these outlets aren’t UL-listed, so there is a safety/risk concern to using them.

  2. Buck James says:

    I was able to set up and use Alexa in less than 5 minutes. I also have Google WiFi which switches between 2.4 & 5 GHz automatically

  3. rleneway says:

    I want to demo using the smart plug in a college network but need to find out the MAC address to let the network admin make ann exception to the college’s network filter. Where do I find the MAC address for the smart plug?.

    • Brian_Goodacre says:

      If you have your own router, you can connect it to that router, and then look at the info of the connected devices.

  4. David St Laurent says:

    How can I connect remotely when I’m away from home?

  5. Curtis P says:

    Very easy to setup. No problems at all and I bought the 4 pack. Connected all 4 and to Alexa in 10 minutes. Use new VeSync app with green background. Works a lot better than ihome plug

  6. Michelle Nabours says:

    I had this set up on an older router with no trouble, but we got a new one and I can’t for the life of me get it set up.
    I have tried the steps you suggest, during set up I get a message on my phone that says there was a network error. Then I get a message from the app saying it was successful and returns me to the home page however, the outlet is not on the home page. And mysteriously, my phone has switched over to the 5GHz network, so I have to start everything over.
    I have tried this no less than 5 times, trying every way I can think of unsuccessfully. Any advice would be appreciated. I hate that I may have to scrap these for a different outlet. I have 4 of them, and can’t connect any of them.

    • Brian_Goodacre says:

      You should try forgetting the 5GHz on your phone so the phone will not try connect to it. After you set up your outlet, then add that network back to your phone.

      • Bill says:

        Agreed, that it is what I had to do to get the first one working/programmed. After that, the second one worked as quickly as advertised.

  7. Josh says:

    Thanks so much for this, really helpful.
    My plan was to use this to control the exhaust fan in my kitchen as it comes on automatically when you turn on the light, but when not cooking it’s just very noisey. This plug was the perfect size to fit into the fan enclosure, but I couldn’t get it to work reliably until I followed your steps. They say it’s the little things, and yeah this is a little thing but really happy I got it working with your help.

  8. fanda says:

    I had trouble adding 2 more outlets. I was using version of VeSync (1.71), this version has issues with this process.
    After searching GooglePlay found the newer version (2.4.2), installed and all is working as expected.

  9. Crissy Keegan says:

    Our outlets say connected but no internet connection. Internet works fine. How do we fix this so that we can actually use the outlets?

  10. John Beaumont says:

    Same problem as Crissy Keegan. When setting up the outlet says it connected but no internet connection. Yes, I’ve made sure I’m on my 2.4 GHz connection. I’ve tried other network connections (all 2.4 GHz) and get the same message. Obviously I am connected to the internet. Frustrating to say the very least!! Anyone come up with a solution yet?

  11. Cristin Keegan says:

    Is your phone an android device? We have found that there are no issues with my Apple phone. It doesn’t work with my husband’s androids. We wound up switching to completely different WiFi outlets and have had no issues at all.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s