Temporary fix for updating external HPFS/NTFS/exFAT hard drive’s permissions so Plex can access

When I plugged in my external hard drive that was on Windows to a Linux machine (Raspberry Pi 3), it was automatically mounted at /media/brian/Brian-HD, but the permissions were drw- --- --- 1 brian brian. I needed Plex to be able to see and use the hard drive, but no matter how much I tried to open up permissions, the ls -l command never changed.

Failed attempts to update permissions

sudo -R chmod 660 /media/brian/
sudo addgroup brian plex
sudo addgroup plex brian

Finding out that the drive is an exFAT.

sudo fdisk -l 
Device Boot Start End Sectors Size Id Type 
/dev/sda1 256 488378111 488377856 1.8T 7 HPFS/NTFS/exFAT

What worked for me

PLEX support forums has an article specifically on how to mount NTFS hard drives (but exFAT works too) so you can get permissions for PLEX to see the files. But their article is old and has broken links, so I will restate it with updated links:

# Run and get the UUID of your device

# Edit /etc/fstab
sudo nano /etc/fstab

# Add this line to the bottom 
UUID=<UUID from before without quotes and brackets> /media/brian exfat permissions,auto 0 0

# Unmount your device
sudo umount /media/brian/Brian-HD

# Try mounting and troubleshoot
sudo mount /media/brian


The last step will work, but you might have to do some troubleshooting to make sure the format type is right and the mount location is correct.



This entry was posted in Hardware, How-To, Plex and tagged , , , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s